Impression 3D

D’une révolution nous passons aux évolutions, l’imprimante 3D est en passe de transformer notre quotidien en se démocratisant avec des modèles de plus en plus performants et simples d’usage.

L’impression 3D est une formidable aventure que nous vous proposons de partager au travers de ce forum.
Forum spécialisé BQ Witbox, Hephestos , Witbox 2, Hephestos 2, Witbox Go!

Octoprint ne détecte pas l'imprimante

Améliorations spécifiques à L'Hephestos 1 BQ et rien d'autre

Retour vers Améliorations Hephestos

par Kris75 » Lun Mars 05, 2018 10:01 pm

Capture.JPG
Capture.JPG (44.39 Kio) Consulté 630 fois
Bonjour

J'ai l'hephestos 2017. Je suis en train de tenter de la connecter à Octoprint.
J'accède bien à Octoprint via l'explorateur,
la connection entre le raspberry et l'imprimante vie le mini port USB se fait bien (l'imprimante s'allume en étant juste connecté au raspberry)
mais Octoprint ne de détecte pas l'imprimante

Lorsque je tente de me connecter, j'ai le droit au message d'erreur "State: Error: Failed to autodetect serial port, please set it manually."

Est-ce que l'un de vous a une idée pour me débloquer?
Kris75
Membre actif
 
Message(s) : 25
Inscrit le : Dim Jan 15, 2017 10:05 pm
Imprimante 3D: Hephestos

par Jacques » Lun Mars 05, 2018 10:40 pm

Si possible sélectionnez le port com qu'il vous propose ou allez dans le gestionnaire de périphériques pour y trouver le numéro de port com
Dans Baud rate, mettez 115200
Ca devrait mieux fonctionner

Note : l'allumage par le port usb est automatique simplement par le fait que l'usb du Rasberry donne du 5V. Cependant, pour fonctionner l'imprimante aura besoin de son 12V
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4121
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par Kris75 » Mar Mars 06, 2018 12:59 pm

Merci pour la réponse. J'ai mis à jour le champ Baud Rate comme indiqué, par contre dans Serial Port, je n'ai pas d'autres choix que Auto. Et cela ne fonctionne toujours pas.
Kris75
Membre actif
 
Message(s) : 25
Inscrit le : Dim Jan 15, 2017 10:05 pm
Imprimante 3D: Hephestos

par paraglandeur » Mar Mars 06, 2018 2:05 pm

Voici ma config :
Octoprint_cnx.gif
Octoprint_cnx.gif (6.74 Kio) Consulté 610 fois


Octoprint_cnx_settings.gif
Octoprint_cnx_settings.gif (29.11 Kio) Consulté 610 fois
paraglandeur
Contributeur actif
 
Message(s) : 214
Inscrit le : Mer Fév 03, 2016 2:01 pm
Imprimante 3D: Hephestos

par Kris75 » Mar Mars 06, 2018 2:25 pm

Merci, j'ai la même config à part le port où je n'ai que 'AUTO' comme choix.
J'ai essayé de me connecter sur les différents ports USB du raspberry mais ça ne change pas.
J'ai commandé un câble blindé pour voir si ça peut avoir une influence comme indiquée sur certains forum, je l'aurais jeudi.
Si certains ont d'autres idées, je suis preneuse
Kris75
Membre actif
 
Message(s) : 25
Inscrit le : Dim Jan 15, 2017 10:05 pm
Imprimante 3D: Hephestos

par Jacques » Mar Mars 06, 2018 2:40 pm

Il est probable que votre driver USB ne soit pas installé
Regardez ici https://projetsdiy.fr/installer-ide-arduino-linux-arm-raspberry-pi-orange-pi-odroid-armbian/
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4121
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par Kris75 » Mar Mars 06, 2018 3:49 pm

Je ne comprends pas bien le lien. Je n'ai pas installé Arduino sur mon Raspberry.
Kris75
Membre actif
 
Message(s) : 25
Inscrit le : Dim Jan 15, 2017 10:05 pm
Imprimante 3D: Hephestos

par Jacques » Mar Mars 06, 2018 4:41 pm

J'ai été un peu vite, ce lien n'a rien à voir avec votre problème.
En principe le fichier downloadé du site Octoprint comprend tout pour fonctionner.
Par contre suivant le câble mini USB que vous utilisez vous n'aurez aucun transfert de données (par exemple avec un câble exclusif de charge)
Regardez sur votre câble vous devez avoir un symbole de connexion réseau. Sinon essayer le câble d'origine PI
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4121
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par paraglandeur » Mar Mars 06, 2018 7:19 pm

Je n'avais pas bien lu votre 1er post.
Votre branchement n'est pas correct, car le mini port USB du Raspberryt ne sert que pour l'alimentation de la carte.

Image


Pour un branchement correct, il faut utiliser les grosses prises USB du Raspberry.
Utilisez un chargeur USB de téléphone pour alimenter le Raspberry via la microUSB
(Il faut une alim qui délivre au moins 2A)
paraglandeur
Contributeur actif
 
Message(s) : 214
Inscrit le : Mer Fév 03, 2016 2:01 pm
Imprimante 3D: Hephestos

par Kris75 » Mar Mars 06, 2018 7:58 pm

paraglandeur : c'est bien la connections que j'ai fait

J'ai tenté avec d'autres câbles en vain
Mais les ports USB sont fonctionnels puisqu'il détecte bien des clés USB
Kris75
Membre actif
 
Message(s) : 25
Inscrit le : Dim Jan 15, 2017 10:05 pm
Imprimante 3D: Hephestos

par paraglandeur » Mar Mars 06, 2018 9:09 pm

Pourtant dans ton 1er post, tu dis que tu as connecté l'imprimante au Raspberry via le miniUSB...
C'est cela que je trouvais étrange.

Kris75 a écrit:...
la connection entre le raspberry et l'imprimante vie le mini port USB se fait bien (l'imprimante s'allume en étant juste connecté au raspberry)...
paraglandeur
Contributeur actif
 
Message(s) : 214
Inscrit le : Mer Fév 03, 2016 2:01 pm
Imprimante 3D: Hephestos

par Kris75 » Mar Mars 06, 2018 9:47 pm

C'est sur l'imprimante que j'utilise le port mini usb.
Kris75
Membre actif
 
Message(s) : 25
Inscrit le : Dim Jan 15, 2017 10:05 pm
Imprimante 3D: Hephestos

par paraglandeur » Mer Mars 07, 2018 12:54 am

D'acccccooooooord, au temps pour moi, je n'avais pas compris !
paraglandeur
Contributeur actif
 
Message(s) : 214
Inscrit le : Mer Fév 03, 2016 2:01 pm
Imprimante 3D: Hephestos

par Jacques » Mer Mars 07, 2018 8:20 pm

Regardez sur votre câble vous devez avoir un symbole de connexion réseau.
SI vous ne savez pas utilisez un câble d'origine de téléphone qui permet le transfert de données.
Blindé ou pas ca n'a aucune importance à 115200bps
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4121
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos


Retour vers Améliorations Hephestos