Impression 3D

D’une révolution nous passons aux évolutions, l’imprimante 3D est en passe de transformer notre quotidien en se démocratisant avec des modèles de plus en plus performants et simples d’usage.

L’impression 3D est une formidable aventure que nous vous proposons de partager au travers de ce forum.
Forum spécialisé BQ Witbox, Hephestos , Witbox 2, Hephestos 2, Witbox Go!

reset marlin constant

Posez ici vos questions techniques avec ou sans rapport à l'impression 3D

Retour vers Sujets de technique générale

par poezadri » Dim Fév 18, 2018 1:35 pm

Bonjour , je viens vers vous car j'ai un petit soucis , déjà je vous d'écrit ma machine moteur Wantai 2.5A 400pas par tour, dvr8825 pour les stepper en 1/32 de pas tension de référence 0.72V, ramps 1.4 plus arduino mega pour le contrôle, firmware marlin RC7(déja tester avec les autre version ça fait pareil),type alim atx , je précise que la machine fonctionne très bien même sur de longues impression, et que j'ai vérifié toute les sources de probleme d'ordre électrique, il n'y en a pas.
je pencherai plus pour un probleme de firmware, sans vouloir orienter qui que ce soit j'ai lu que dans mon cas le watchdog pourrai ne pas avoir le temps d’être acquitter je présise que le probleme m'arrive seulement sur de grande pièce sur le plan horizontale aucun probleme sur le plan verticale,et sa a l'air de fonctionner si je descend les vitesse en dessous de 30% donc environ 20mm/s, sinon hors impression par exemple durant le palpage du plateau avec buse et plateau allumée et des vitesse de l’ordre de 300mm/s aucun problème,
j'avais aussi penser à un probleme d’ampérage et au reset du fusible qui est donner pour 4.6A en 12v mais après sont remplacement pour un plus puissant le soucis continu et l'alimentation ne ce mets ni en sécurité , et na pas de baisse de tension elle est donner pour 30 A en 12V , les polulu sans ventilation on une température de l'ordre de 45° pas de probleme de perte de pas
j'espere avoir donner assez d'information et que quelqu'un pourra m'aider
merci d'avance
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par Jacques » Dim Fév 18, 2018 2:12 pm

Si comprends bien votre problème est un reset général (retour au menu du début) lors d'une longue impression.
Un reset ne peut se faire que par le bouton reset, une coupure d'alimentation ou le watchdog, s'il est activé (ca reste à démontrer).

- Vérifiez que ce n'est pas lié à la lecture de la carte SD. Lancez une impression et retirez la carte SD pendant l'impression.
Si elle reboot, ca peut être une piste.

- Débranchez votre câble reset externe si vous en avez un.

- Isolez l'alimentation de la carte Arduino en l'alimentant par le port USB (transfo ou PC mais attention à la veille)
Dans ce cas le 5V viendra de l'USB et plus du 12V.
Si ca fonctionne c'est que vous avez un problème votre 12v, avec la RAMPS, le régulateur Arduino ou un mauvais contact quelque part.
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4219
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par poezadri » Dim Fév 18, 2018 2:29 pm

comment expliquer que cela ce passe toujours au même point sur la même distance le probleme serait sur la carte sd j'aurai les même soucis sur le plan verticale une pièce de 10*10* 15cm de haut a 60mm/s pas de soucis une pièce de 25*6*6cm de haut sa passe pas des quel commence la grande longueur(la premiere couche pas de souci vitesse plus basse des la deuxieme des le premier contour elle reset a environ 23cm en baissant la vitesse a 20mm/s la l'imprimante passe et je confirme que le watchdog est actif dans marlin
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par poezadri » Dim Fév 18, 2018 2:47 pm

j'ai effectuer les test donc pas de soucis sur la sd j'ai retirer la carte l'impression c'est arrêter j'ai remis la carte puis repris l'impression en USB le soucis reste le même comme je les dit je suis certain du coter électrique/électronique j'ai assez de stock chez moi pour faire des test
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par Jacques » Dim Fév 18, 2018 3:30 pm

Un câble moteur abimé peut occasionner un reboot
Changez vos câble moteur X, Y et extrudeur suivant votre configuration mécanique (ce qui bouge)
On peut imaginer qu'un câble est abimé dans le chemin de câble et suivant le mouvement il se coupe et fait des parasites sur l'alimentation.
J'ai déjà eu ce problème avec le câble de l'extrudeur
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4219
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par poezadri » Dim Fév 18, 2018 3:39 pm

aucun moteur en mouvement c'est une delta
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par Jacques » Dim Fév 18, 2018 4:54 pm

A part ,'alimentation par l'USB, je ne vois pas...
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4219
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par poezadri » Dim Fév 18, 2018 8:51 pm

je viens de désactiver le watchdog a première vu le probleme est résolu j'arrive enfin a imprimer a des vitesse correcte sur des grandes pièces on verra bien dans 4h30 mais plus ce bug constant des que j'augmente la vitesse la première couche buggait des que je poussait a 160% sur l’écran de contrôle et la elle a entamé la deuxième alors j'ai de bon espoir j'ai bien sur redescendu la vitesse a 100% car 90mm/s je suis pas sur du resultat
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par Jacques » Dim Fév 18, 2018 9:25 pm

Le timeout watchdog se configure dans un registre hardware (WDTO). Sur une Delta les calculs sont plus longs, c'est probablement la raison

Attention, en cas de plantage CPU la chauffe ne sera plus régulée, le watchdog est là pour couper tout en dernière limite.
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4219
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par poezadri » Dim Fév 18, 2018 10:05 pm

quentendez vous par la?
Dernière édition par poezadri le Dim Fév 18, 2018 10:07 pm, édité 1 fois.
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par Jacques » Dim Fév 18, 2018 10:07 pm

Oui, le chauffage de la buse
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4219
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par poezadri » Dim Fév 18, 2018 10:11 pm

donc la régulation pid n'est plus effective c'est bien ça on passe en tout ou rien sur un cycle complet
poezadri
Nouveau membre
 
Message(s) : 8
Inscrit le : Dim Fév 18, 2018 1:05 pm
Imprimante 3D: opt one, prusa i3, opt two , et la 4eme na pas de nom

par Jacques » Dim Fév 18, 2018 11:03 pm

Non, pas du tout le PID fonctionne toujours et le reste aussi tout à fait normalement.
Le Watchdog est un registre interne du CPU.
Normalement ce registre décompte du temps en partant de base à une seconde.
A chaque fois que le PGM le peut il remet ce registre à 1 seconde avec la commande WD RESET.
Si ce décompte arrive à 0 (pas de reset dans la seconde suivant le dernier reset), le CPU fait automatiquement un global reset.
Ce control est complètement hardware, il permet, si le PGM se plante ou entre dans une boucle infinie, de couper tout les processus et donc en particulier la chauffe qui pourrait bien ne plus être régulée (risque de feu).
Le Watchdog est une sécurité hardware, il faut en avoir conscience.
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, 0134078285.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 4219
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos


Retour vers Sujets de technique générale